Skip to main content

On-Screen Takeoff, Quick Bid, Digital Production Control: Repairing Crystal Reports

  • June 28, 2016
  • 0 replies
  • 91 views

Issue

Previewing any Tab other than the Image Tab in On-Screen Takeoff and/or generating Quick Bid Reports does not work.

Cause

On-Screen Takeoff and Quick Bid use Crystal Reports 9 and Crystal Decisions 2.0 to print reports, tabs, lists, etc. (everything but the Takeoff Tab in On-Screen Takeoff).

Sometimes, during installing upgrades, these installations get corrupted or stop working. Uninstalling and reinstalling the application does not fix this issue. You will need to remove the installations of Crystal Reports and Crystal Decisions from the computer in order to get the application installers to reinstall and re-register these products.

You will be deleting Common Files in the Program Files (or Program Files (x86)) directories. Only a Windows Administrator will be able to perform this operation.<

Resolution

To repair Crystal Reports and Crystal Decisions, perform the following steps:

  • Open the Control Panel (consult your Windows documentation for details)
  • Click Installed Apps
  • Uninstall On-Screen Takeoff and Quick Bid (this does not affect any information stored in the databases (conditions, takeoff, assemblies, etc).

Once uninstalled,

  • Open Windows Explorer (substitute "C:\Program Files (x86)" for 64-bit systems) in the instructions below)
  • In Windows Explorer, browse to "C:\Program Files\Crystal Decisions" and delete the Report Designer Component directory
  • Next, still In Windows Explorer, browse to "C:\Program Files\Common Files\Crystal Decisions" and delete the "2.0" directory

Once these two folders are deleted, you will need to run the Windows Registry Editor

The following steps require you to modify the Windows registry and possibly system files. Modifications to the Windows registry and/or system files, if not done correctly, can cause Windows to stop working. Please contact an IT Professional to assist you if you are unfamiliar with any of these processes or terms.

  • Click Start,
  • Type "regedit" in the Start/Search field,
  • Press the <Enter> key on the keyboard

Once the Registry Editor opens,

  • Browse to the following keys and delete them:

KEY_CURRENT_USER\Software\Crystal Decisions\9.0

HKEY_LOCAL_MACHINE\SOFTWARE\Crystal Decisions\9.0

  • Close the Registry Editor
  • Reinstall the applications, starting with Quick Bid

Crystal Reports and Crystal Decisions will be reinstalled during the installation process.


Related Articles